Back to overview
Downtime

API is down

Nov 24, 2025 at 9:56am UTC
Affected services
Incredible Chat
Incredible LLM API

Resolved
Nov 24, 2025 at 10:48am UTC

Supabase has resolved their issues

Updated
Nov 24, 2025 at 10:06am UTC

Supabase is getting back online

Created
Nov 24, 2025 at 9:56am UTC

Our vendor Supabase is experiencing issues which is affecting us